Forem Creators and Builders

Ben Halpern
Ben Halpern

Posted on

DigitalOcean: forem-traefik.service: Job forem-traefik.service/start failed with result 'dependency'.

While running this command on my DigitalOcean install:

sudo systemctl restart forem-traefik.service
Enter fullscreen mode Exit fullscreen mode

The command is stalling, and I'm getting this output in my logs:

Aug 12 17:14:30 www.mynewforem.com systemd[1]: Dependency failed for Forem Traefik Service.
Aug 12 17:14:30 www.mynewforem.com systemd[1]: forem-traefik.service: Job forem-traefik.service/start failed with result 'dependency'.
Enter fullscreen mode Exit fullscreen mode

Can anyone help me make sense of this?

Discussion (2)

Collapse
derekenos profile image
derekenos

Hi Ben!

On a fresh DigitalOcean deployment, the services looked all sad like this:

$ systemctl list-units forem*
  UNIT                     LOAD   ACTIVE     SUB          JOB   DESCRIPTION             
  forem-imgproxy.service   loaded active     running            Forem Imgproxy Service
  forem-openresty.service  loaded inactive   dead         start Forem OpenResty Service
  forem-pod.service        loaded active     running            Forem pod service
  forem-postgresql.service loaded active     running            Forem Postgresql Service
  forem-rails.service      loaded inactive   dead         start Forem Rails Service
  forem-redis.service      loaded active     running            Forem Redis Service
  forem-traefik.service    loaded inactive   dead         start Forem Traefik Service
  forem-worker.service     loaded inactive   dead         start Forem Worker Service
  forem.service            loaded activating auto-restart start Forem Service
Enter fullscreen mode Exit fullscreen mode

I was able to make them happy with:

sudo systemctl start forem-container.service
Enter fullscreen mode Exit fullscreen mode

some time later...

$ systemctl list-units forem*
  UNIT                     LOAD   ACTIVE SUB     DESCRIPTION             
  forem-imgproxy.service   loaded active running Forem Imgproxy Service
  forem-openresty.service  loaded active running Forem OpenResty Service
  forem-pod.service        loaded active running Forem pod service
  forem-postgresql.service loaded active running Forem Postgresql Service
  forem-rails.service      loaded active running Forem Rails Service
  forem-redis.service      loaded active running Forem Redis Service
  forem-traefik.service    loaded active running Forem Traefik Service
  forem-worker.service     loaded active running Forem Worker Service
  forem.service            loaded active exited  Forem Service
Enter fullscreen mode Exit fullscreen mode

Then sudo systemctl restart forem-traefik worked.

Collapse
ben profile image
Ben Halpern Author

Woohoo it worked, let's garden!

Really great to see you around these parts Derek. ❤️