Forem Creators and Builders

Akhil Naidu
Akhil Naidu

Posted on • Updated on

A bug within the live Forem Instance, "Authentication Issue".

New Update: Bug got fixed and for further details click here




I thought this deserves a place here and if anyone can reproduce it in different browsers, mention them. Also, if you have any suggestions comment below or contribute it in the issues section.

Describe the bug

This is related to the live Forem Instance. The user is getting logout and the feed is empty in certain cases. The cases are mentioned below.

To Reproduce

Case 1

  1. Login to Forem
  2. Use the Forem logo and open Forem in a new tab (Right-click on the mouse)

Case 2

  1. Login to Forem
  2. Click on Forem logo (no change at this stage)
  3. Double click Forem Logo (the same issue arises)
  4. If you can't produce the error, repeat double-clicking Forem Logo

Expected behavior

User should not be logged out and should be able to view the feed

Additional Information

  1. You can reproduce these cases in chrome and Incognito chrome. I never tested this in other browsers.
  2. Double-clicking and opening in a new tab don't result in any errors if it a mobile device.
  3. This is not an issue with my device, I checked it in a few other devices, also as Dev.to is not producing any such errors even though it is running through the same code.

If anyone can reproduce this in other browsers; like Firefox, Safari, Internet Explorer, or Opera. Please do mention it, it will provide valuable information.

Discussion (4)

Collapse
bolsonusc profile image
bolsonusc

It happens in Sari: recordit.co/bbDxb1ns0Y

Collapse
avalerionv profile image
Dawood Khan Masood

Same for me. I guess the issue is with the cache.

Screenshot: forem.dev/remoteimages/i/wfzfn91uv...

Collapse
0xc000005 profile image
0xC00005

Same, I ran into this question in the Edge browser on both win10 and Andriod.

Collapse
bolsonusc profile image
bolsonusc

I can reproduce this on Safari.