Forem Creators and Builders 🌱

Discussion on: Unable to fetch blogs from "RSS Feed URL"

Collapse
 
pandeybk profile image
Balkrishna Pandey Author

Yes, I did; in fact, the same RSS feed URL works with dev.to. I tried with wordpress feed url (works in dev.to but not on goglides.dev). It's something on my hosted forum. I tried enabling the debug log but got no results. Is there any log file I can check?

Collapse
 
ellativity profile image
Ella (she/her/elle)

Hmmm πŸ€”What is your self-host configuration? Which process did you follow to get your Forem installed?

Have you run

sudo foremctl deploy

to ensure your Forem version is the latest version?

Thread Thread
 
pandeybk profile image
Balkrishna Pandey Author

I am using Kubernetes. The version I am using isquay.io/forem/forem@sha256:bdaae5653917441c0aad80717ca52396622dda98f1a1ac277d8adf16bd267f76, this is the latest update I upgraded yesterday (was seeing issue with previous version as well)quay.io/forem/forem@sha256:0c00c2cc12b19f689d7b7f7e0d54fbaf7298ad55373c5f5692590128c4dfb09a. My only concerns is non of the component throwing any error :). If you look at the logs, everything looks good. I think we are suppressing logs which is making it harder to debug.

Thread Thread
 
pandeybk profile image
Balkrishna Pandey Author

I wonder if it's something to do with nginx ingress controller proxy settings. In a selfhosted repo we are using nginx and traefik.(github.com/forem/selfhost/blob/mai...). In my deployment I am only using nginx ingress controller. I wonder if its proxy settings causing problem. Ideally it shouldn't, but hard to tell.

Thread Thread
 
pandeybk profile image
Balkrishna Pandey Author

In the description above, I've included a debug log; do you think someone from the development teams could have a look at it? Any direction will be helpful.

Thread Thread
 
pandeybk profile image
Balkrishna Pandey Author

This is a log when I press "Fetch Feed now" button.