Forem Creators and Builders

Discussion on: This is the best optimization PR.

Collapse
manuel profile image
Manuel

Thanks Akhil! The error is that after merging the changes from forem branch, i tried to recreate the assets with:

docker-compose exec rails bundle exec rake assets:precompile
Enter fullscreen mode Exit fullscreen mode

However there is an error and is creating a file called: postcss_error.log and the error seems to be on a css file:

Expecting "SUB", "LPAREN", "NESTED_CALC", "NUMBER", "CSS_VAR", "LENGTH", "ANGLE", "TIME", "FREQ", "RES", "EMS", "EXS", "CHS", "REMS", "VHS", "VWS", "VMINS", "VMAXS", "PERCENTAGE", "expression", "math_expression", "value", "css_variable", "css_value", got unexpected "PREFIX"
    at /opt/apps/forem/public/assets/minimal-ce170b82da2bad10bc32420e34957902affc3ef433c0f625fb31926084604802.css:1:222887
Enter fullscreen mode Exit fullscreen mode

Before this I was making merge every 3 or 4 days without and issue, but since last week i got the error.

Thread Thread
akhil profile image
Akhil Naidu Author • Edited on

So, I suppose you are using Forem in development on VPS suing docker? (If this is not the case, let me know)

If this is the case, you can try these to forcefully stop all the services and start services with the updated code.

  1. docker-compose down
  2. Update your Forem folder. If you have your own fork that would be great and more preferable. git push origin main
  3. docker-compose up -d (wait for a while, as sidekiq and web workers are loading in background)
Thread Thread
manuel profile image
Manuel • Edited on

Yeah thats exactly what i was doing, after the docker-compose up -d all seems to be fine however when enter the app there are some css missing and tried to recreate but got the issue with that specific css.

I also tried removing the assets folder but getting the same error as well.

Thread Thread
akhil profile image
Akhil Naidu Author • Edited on

Ok, I'm not sure how to recreate this in my own development instance, but I can sure suggest you a thing.

Hard reset
Enter fullscreen mode Exit fullscreen mode

Yes, I really mean it.

As you are in development insatnce, there is no need to worry of anything. You can remove everything and start everything new in 5 minutes and within 30minutes you willl have a new insatce.

But if you have configured something and you need to take backup of them, which is not an adviceable thing to do have in development instances. But there is a way for you to backup. There are many tutorials in youtube in how to backing up and restoring a something.dump(a postgress backup file). Follow with one of them and store your data. But I'm not sure how it will work, if you are not using s3 as storage.

Thread Thread
akhil profile image
Akhil Naidu Author

Remember to do this on caution, I'm suggesting this because of few reasons.

  1. I can't recreate your situation
  2. You are using development instance
  3. You are having this issue from few days.

Consider this above comment only as a reminder, rather than the only way of solving this.

Thread Thread
manuel profile image
Manuel

Thanks Akhil! I am going to debug more on the weekend to see what could be the issue, yeah if its no other way I will do a hard reset. I have backup of the database so just need to restore in the volume of the postgress docker. Will let you know my findings! thanks again for all the help your tutorials rocks!

Thread Thread
manuel profile image
Manuel

Just for the update, today i just download the most updated changes to my branch and the issue was solved, didnt know what happened.

Thread Thread
akhil profile image
Akhil Naidu Author

That is good to know. So, I'll take a note of it.

If any kind of .css error; replacing the fork will fix it.