Forem Creators and Builders 🌱

Discussion on: cannot edit a comment without refresh

Collapse
 
johndoes profile image
nobody Author • Edited on

thank you for reply

Repository: quay.io/forem/forem:latest SHA256: 6e792b0ec4d12418576ea7993d81aa858479651a2b1eb33a43843260b9d27e00 Created: 23 hours ago

edit: I just run

foremimg quay.io/forem/forem:testing


foremctl update


foremctl depoly

to update the image to the testing branding, but the issue still persists.

Collapse
 
jamie profile image
Jamie Gaskins

@charliebbs You have a typo in foremctl deploy in there. Is that how you typed it into the command line? If so, you may still be running the previous version.

I'm unable to reproduce this on my own selfhosted Forem instance running on the latest container image. You mention you're using Cloudflare, though, and I'm not, which makes me think this might be a caching issue with the CDN. Specifically, it could be caching pages with outdated CSRF tokens in them. If you point your DNS directly at your Forem instance, does the issue persist?

Thread Thread
 
johndoes profile image
nobody Author • Edited on

yes, I think Cloudflare is the issue. I deployed another development instance with docker-compose yesterday. Everything works fine if I connect to it directly with its ip address. However, if I use reverse proxy + Cloudflare to connect to it, the bug appears again. Just want to let everybody who reads here realize Forem is currently NOT compatible with Cloudflare.
Thank you Jamie.